URI - BEECROWD - BEE Online Judge Solution 1037 | Interval - URI - BEECROWD - BEE 1037 Solution in C,C++,Python
You must make a program that read a float-point number and print a message saying in which of following intervals the number belongs: [0,25] (25,50], (50,75], (75,100]. If the read number is less than zero or greather than 100, the program must print the message “Fora de intervalo” that means "Out of Interval".
The symbol '(' represents greather than. For example:
[0,25] indicates numbers between 0 and 25.0000, including both.
(25,50] indicates numbers greather than 25 (25.00001) up to 50.0000000.
Input
The input file contains a floating-point number.
Output
The output must be a message like following example.
Input Sample | Output Sample |
25.01 | Intervalo (25,50] |
25.00 | Intervalo [0,25] |
100.00 | Intervalo (75,100] |
-25.02 | Fora de intervalo |
URI Online Judge Solution 1036 | Bhaskaras Formula - URI 1036 Solution in C,C++,Python:
#include<stdio.h>
int main()
{
float n;
scanf("%f", &n);
if(n < 0 || n > 100){
printf("Fora de intervalo\n");
}else{
if(n >= 0 && n <= 25){
printf("Intervalo [0,25]\n");
}else if(n > 25 && n <= 50){
printf("Intervalo (25,50]\n");
}else if(n > 50 && n <= 75){
printf("Intervalo (50,75]\n");
}else{
printf("Intervalo (75,100]\n");
}
}
return 0;
}
My Halp please
ReplyDelete